Книга знаний

Рекламное место пустует
1С:Предприятие / v8 / Приемы программирования / Формы

v8: Как после ввода перейти на следующую строку табличного поля?

Т.е. человек должен просто установить курсор, в нужную строку, ввести число, нажать Enter, и курсор надо передвинуть на следующую строку для ввода следующего числа (как в Excel). Автор статьи: Волшебник | Редакторы:
Последняя редакция №3 от 21.02.06 | История
URL: http://kb.mista.ru/article.php?id=49

Перем мСменитьСтроку;
Перем мСледующаяСтрока;

//эта процедура должна быть назначена как обработчик события ПриОкончанииРедактирования
//в свойствах табличного поля
Процедура ТаблицаХарактеристикНоменклатурыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)

    СтрокаТЧ = Элемент.ТекущаяСтрока;
    Если СтрокаТЧ <> Неопределено Тогда
        ИндексСтрокиТЧ = ТаблицаХарактеристикНоменклатуры.Индекс(СтрокаТЧ);
        Если ИндексСтрокиТЧ >= 0 И ИндексСтрокиТЧ+1 < ТаблицаХарактеристикНоменклатуры.Количество() Тогда
            мСледующаяСтрока = ТаблицаХарактеристикНоменклатуры[ИндексСтрокиТЧ+1];
            мСменитьСтроку = Истина;
        КонецЕсли; 
    КонецЕсли; 

КонецПроцедуры 

//эта процедура должна быть назначена как обработчик события ОбновлениеОтображения
//в свойствах формы
Процедура ОбновлениеОтображения()

    мОбновлениеОтображения(ЭтаФорма);
    Если мСменитьСтроку Тогда
        мСменитьСтроку = Ложь;
        ЭлементыФормы.ТаблицаХарактеристикНоменклатуры.ТекущаяСтрока = мСледующаяСтрока;
    КонецЕсли; 

КонецПроцедуры // ОбновлениеОтображения()

мСменитьСтроку = Ложь;


Рекомендуется также установить свойство колонки "Режим редактирования" в значение "Вход при вводе".



Другой вариант - использовать WSH и метод SendKeys(стрелка вниз).
см. подробнее: Книга знаний: Windows Script Hosting (WSH). Коллекция ссылок;
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика