Книга знаний

Рекламное место пустует
1С:Предприятие / Приемы программирования / Коллекции значений

Массивы, структуры, соответствия и списки значений в 1С 8.2

Пример добавления элементов и перебора в соответствующих коллекциях значений.romix
Последняя редакция №0 от 10.08.11
URL: http://kb.mista.ru/article.php?id=835

&НаКлиенте
Процедура Сформировать(Команда)
    м= Новый Массив;
    м.Добавить("ааа");
    м.Добавить("ббб");

    размер=м.Количество();
    Сообщить("Размер: "+размер);
    первое=м[0];
    второе=м[1];
    Сообщить("Первое: "+первое);
    Сообщить("Второе: "+второе);
    Для Каждого ЭлементМассива Из м Цикл 
        Сообщить("Элемент массива: "+ЭлементМассива); 
    КонецЦикла;    
    
    м[0]="ввв";
    
    м.Очистить(); 
    размер=м.Количество();
    Сообщить("Размер: "+размер);
    
    //////////////////////////////////////////
    с = Новый Структура; 
    с.Вставить("Цвет", "Красный");
    с.Вставить("Размер", 45);
    Сообщить("Цвет: "+с.Цвет);
    Сообщить("Размер: "+с.Размер);
    
    Сообщить("Цвет: "+с["Цвет"]);
    Сообщить("Размер: "+с["Размер"]);
    
    Для Каждого Элемент из с Цикл 
        Сообщить(Элемент.Ключ + ": " + Элемент.Значение); 
    КонецЦикла;     
    
    Сообщить("Количество: "+с.Количество());
    с.Очистить();
    
    //////////////////////////////////////////
    c = Новый Соответствие;
    Сотрудник="zzz"; //Тут может быть ссылка на элемент справочника или др. объект
    Возраст=30;
    с.Вставить(Сотрудник, Возраст);
    Для Каждого Элемент из с Цикл 
        Сообщить(Элемент.Ключ + ": " + Элемент.Значение); 
    КонецЦикла;     
    
    
    /////////////////////////////////////////
    сз = Новый СписокЗначений;
    Сотрудник="xxx";
    Представление="xxx";
    сз.Добавить(Сотрудник, Представление);
    Сотрудник="yyy";
    Представление="yyy";
    сз.Добавить(Сотрудник, Представление);
    Для Каждого ЭлементСписка Из сз Цикл 
        Сообщить(ЭлементСписка.Значение); 
    КонецЦикла;     
    
КонецПроцедуры
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2021 | Mista.ru

Яндекс.Метрика