Книга знаний

1С:Предприятие / Приемы программирования / Торговое оборудование

Проверка штрих кода по контрольной цифре

Автор статьи: Anderson | Редакторы: Лефмихалыч
Последняя редакция №4 от 25.06.08 | История
URL: http://kb.mista.ru/article.php?id=674

Ключевые слова: EAN13,EAN8,проверка ШК,контрольная цифра,контрольная сумма


Функция глПроверкаШК(ШтрихКод) Экспорт
    Перем КонтрольнаяСумма,Четные,Нечетные,Общее,Результат,ПроверкаДесятка;
    Если СтрДлина(ШтрихКод)<>13 Тогда
        Возврат 0;
    КонецЕсли;
    
    КонтрольнаяСумма=Число(Сред(ШтрихКод,13,1));
    Для а=1 по 12 Цикл
        Если а%2>0  Тогда
            Нечетные=Нечетные+Число(Сред(ШтрихКод,а,1));
        Иначе
            Четные=Четные+Число(Сред(ШтрихКод,а,1));
        КонецЕсли;                                    
    КонецЦикла;                                        
    Общее=Нечетные+(Четные*3);
    Для х=0 По 9 Цикл  
        ПроверкаДесятка=(Общее+х)/10;
        Если ПроверкаДесятка=Цел(ПроверкаДесятка) Тогда
            Результат=х;
            Прервать;
        КонецЕсли;
    КонецЦикла; 
    
    Если (КонтрольнаяСумма=Результат) Тогда 
        Возврат 1;
    Иначе
        Возврат 0;
    КонецЕсли;
КонецФункции
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2021 | Mista.ru

Яндекс.Метрика