Книга знаний

Рекламное место пустует
1С:Предприятие / Объекты конфигурации / Отчеты

Фамилия в дательном падеже

Функция переводит фамилию, записанную как Иванов И.И. -> Иванову И.И.Автор статьи: romix
Последняя редакция №1 от 13.11.07
URL: http://kb.mista.ru/article.php?id=605

Ключевые слова: фамилия, дательный, падеж


///////////////////////////////////////////////////////////////////////
//Фамилия в дательном падеже
Функция ДательныйПадеж(прм_Фио)
    стр=СокрЛП(прм_Фио);
    п=Найти(стр," ");
    Если п=0 Тогда
        стр1=СокрЛП(стр);//фамилия
        стр2="";//окончание
    Иначе
        стр1=СокрЛП(лев(стр,п));
        стр2=СокрЛП(сред(стр,п));
    КонецЕсли;
        стр1=стр1+" ";
    
    Если Найти(стр1,"о ")>0 Тогда
        //не изменяем
    ИначеЕсли Найти(стр1,"и ")>0 Тогда
        //не изменяем
    ИначеЕсли Найти(стр1,"а ")>0 Тогда    
        стр1=СтрЗаменить(стр1,"а ","ой ");
    ИначеЕсли Найти(стр1,"ая ")>0 Тогда    
        стр1=СтрЗаменить(стр1,"ая ","ой ");
    ИначеЕсли Найти(стр1,"ий ")>0 Тогда    
        стр1=СтрЗаменить(стр1,"ий ","ому ");
    ИначеЕсли Найти(стр1,"ь ")>0 Тогда    
        стр1=СтрЗаменить(стр1,"ь ","ю ");
    Иначе
        стр1=СтрЗаменить(стр1," ","у ");
    КонецЕсли;
    Возврат стр1+ стр2;
КонецФункции
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2021 | Mista.ru

Яндекс.Метрика