Книга знаний

Рекламное место пустует
1С:Предприятие / v8 / Приемы программирования / Формы

v8: Сохранение настроек построителя отчета в стандартных настройках

1С в конструкторе использует слишком сложный метод сохранения настроек построителя. Существует более простой способ.Автор статьи: Гений 1С | Редакторы:
Последняя редакция №2 от 06.06.07 | История
URL: http://kb.mista.ru/article.php?id=542

Ключевые слова: построитель,настройки,сохранение настроек


Добавляем в реквизиты отчета (именно отчета, а не формы, иначе не будет сохраняться) реквизит НастройкиПостроителя с типом "Строка неограниченной длины".
Добавляем его в список "Сохраняемые значения".

Далее, используем такой код:

Процедура ПередСохранениемЗначений(Отказ)
    ...
    НастройкиПостроителя=ЗначениеВСтрокуВнутр(Построитель.ПолучитьНастройки());
    ...
КонецПроцедуры

Процедура ПриОткрытии()
    ...
    Построитель.Текст="";
    Построитель.ЗаполнитьНастройки();
    ...
    Если СокрЛП(НастройкиПостроителя)<>"" Тогда
        Попытка
            Построитель.УстановитьНастройки(ЗначениеИзСтрокиВнутр(НастройкиПостроителя));
        Исключение
        КонецПопытки;
    КонецЕсли;
    ...
КонецПроцедуры
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика