Книга знаний

Рекламное место пустует
1С:Предприятие / v8

v8: Отбор в списках в виде закладок

Реализация отбора в списках объектов в виде закладок, где каждая закладка - какое-нибудь значение отбора.Автор статьи: PR
Последняя редакция №1 от 05.05.07
URL: http://kb.mista.ru/article.php?id=528

Ключевые слова: Отбор, список, закладка.


Иногда бывает удобно смотреть информацию в списках (справочников, документов и т. д.) с разделением записей по закладкам.

Возьмем классический пример, разделение по организациям.
Было бы удобно, скажем, видеть документы в списке только по какой-нибудь одной организации или по всем, при этом переключаясь между этими видами проще, нежели устанавливая или отключая каждый раз вручную отбор по организации.

Я приведу пример реализации механизма для списка документов "Расходная накладная".
Предполагается, что справочник "Организации" иерархический.

Берется форма списка документа "Расходная накладная".

На форму вставляется панель "Организации", со снятым флажком "Распределять по страницам".
Единственная страница обзывается "Все".

Теперь во всю ширину панели вставляется список документов.

Ну и наконец, прописываем два свойства, первое - у формы, второе - у панели.

Процедура ПриОткрытии()
    
    ЭлементыФормы.ДокументСписок.НастройкаОтбора.Организация.Доступность = Ложь;
    
    Спр = Справочники.Организации.Выбрать();
    
    Пока Спр.Следующий() Цикл
        
        Если Спр.ЭтоГруппа Тогда
            Продолжить;
        КонецЕсли;
        
        ЭлементыФормы.Организации.Страницы.Добавить("Организация" + ЭлементыФормы.Организации.Страницы.Количество(), СокрЛП(Спр.Наименование), Спр.Ссылка);
        
    КонецЦикла;
    
КонецПроцедуры

Процедура ОрганизацииПриСменеСтраницы(Элемент, ТекущаяСтраница)
    
    Если ТекущаяСтраница = 0 Тогда
        ДокументСписок.Отбор.Организация.Использование = Ложь;
    Иначе
        ДокументСписок.Отбор.Организация.Использование = Истина;
        ДокументСписок.Отбор.Организация.Значение = ЭлементыФормы.Организации.Страницы[ТекущаяСтраница].Значение;
    КонецЕсли;
    
КонецПроцедуры


Собственно все, пользуйтесь.
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика