Книга знаний

Рекламное место пустует
1С:Предприятие / Приемы программирования / Файловая система

Пример чтения и записи текстовых файлов (Scripting.FileSystemObject)

Объект Scripting.FileSystemObject уже встроен в систему Windows, и позволяет построчно читать и записывать текстовые файлы. В отличие от штатного объекта 1С, файл не хранится целиком в памяти - это ускоряет работу с большими текстовыми файлами.Автор статьи: romix | Редакторы: Гений 1С
Последняя редакция №3 от 21.08.08 | История
URL: http://kb.mista.ru/article.php?id=484

Ключевые слова: файл, текст, прочитать, записать, построчно


Запись текстового файла



///////////////////////////////////////////////////////////////////////
Процедура СоздатьФайл()
    ИмяФайла=КаталогИБ()+"romix_test.txt";
    fso=СоздатьОбъект("Scripting.FileSystemObject");                                                          
    file=fso.CreateTextFile(ИмяФайла, -1, 0); //создать файл, перезаписывая существующий.
    file.WriteLine("Строка1"); 
    file.WriteLine("Строка2"); 
    file.WriteLine("Строка3"); 
    file.Close(); 
КонецПроцедуры


Чтение текстового файла


///////////////////////////////////////////////////////////////////////
Процедура ПрочитатьФайл()
    ИмяФайла=КаталогИБ()+"romix_test.txt";
    fso=СоздатьОбъект("Scripting.FileSystemObject");
    file=fso.OpenTextFile(ИмяФайла, 1, 0, 0); //Открываем файл в режиме "только чтение"           
    Пока file.AtEndOfStream=0 Цикл
      стр=file.ReadLine();
      Сообщить(стр);
    КонецЦикла; 
    file.Close(); 
КонецПроцедуры


См. также:
Книга знаний: Чтение и запись текстовых файлов XML средствами 1С:Предприятие 7.7

Все методы можно почитать здесь:
http://www.citforum.ru/programming/digest/fsovb6.shtml
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2021 | Mista.ru

Яндекс.Метрика