Книга знаний

Рекламное место пустует
1С:Предприятие / Приемы программирования / Встроенный язык

Получить элемент перечисления по его имени (синониму)

Чтобы получить значение перечисления по пользовательскому представлению (синониму) в 1С:Предприятие 8.2 можно при помощи следующего кода.Автор статьи: romix
Последняя редакция №1 от 29.08.13
URL: http://kb.mista.ru/article.php?id=921

Ключевые слова: перечисление


Функция НайтиВидСообщения(прм_имя)
    имя=СокрЛП(прм_имя);
    Для Каждого эл из Метаданные.Перечисления.ИмяПеречисления.ЗначенияПеречисления Цикл
        Если СокрЛП(эл.Синоним)=имя Тогда
            Возврат Вычислить("Перечисления.ИмяПеречисления."+эл.Имя);
        КонецЕсли;    
    КонецЦикла;
    Возврат Неопределено;
КонецФункции


Здесь ИмяПеречисления — наименование перечисления, как оно задано в конфигураторе.
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика