Книга знаний

Рекламное место пустует
1С:Предприятие

Кнопка Продолжить для 1С 8.2

Кнопка Продолжить - продолжает значение, на котором стоит курсор, в следующую строку табличной частиromix
Последняя редакция №0 от 04.04.12
URL: http://kb.mista.ru/article.php?id=879

Ключевые слова: Форма, Табличная часть, Копирование


Функция ИзвлечьИмяРеквизита(прм_Путь)
//Возвращает строку вида Объект.Товары.РодТовара как РодТовара (отбрасывает все что до последней точки)
    стр=СокрЛП(прм_Путь);
    п=1;
    Для й=1 по СтрДлина(стр) Цикл
        Если Сред(стр,й,1)="." Тогда 
            п=й+1;
        КонецЕсли;    
    КонецЦикла;    
    Возврат сред(стр, п);
КонецФункции

Процедура ПродолжитьНаСервере()
//Кнопка Продолжить - продолжает значение, на котором стоит курсор, в следующую строку табличной части    
    табл=ЭтаФорма.ПодчиненныеЭлементы.Страницы.ПодчиненныеЭлементы.ГруппаТовары.ПодчиненныеЭлементы.Товары;
    пд=табл.ТекущийЭлемент.ПутьКДанным;
    имя=ИзвлечьИмяРеквизита(пд);
    нс=табл.ТекущаяСтрока;
    зн=ЭтаФорма.Объект.Товары[нс][имя];
    чСтрок=ЭтаФорма.Объект.Товары.Количество();
    Если чСтрок=(нс+1) Тогда
        Возврат;
    КонецЕсли;    
    ЭтаФорма.Объект.Товары[нс+1][имя]=зн;
    табл.ТекущаяСтрока=нс+1;
КонецПроцедуры


&НаКлиенте
Процедура Продолжить1(Команда)
       ПродолжитьНаСервере();
КонецПроцедуры
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика