Книга знаний

AdBlock убивает бесплатный контент
1С:Предприятие / v8 / Приемы программирования / Формы

v8: Cохранение значений реквизитов формы в файл

Cохранение значений реквизитов формы в файл - таблицу значений тоже сохраняетАвтор статьи: DGorgoN | Редакторы:
Последняя редакция №3 от 02.03.09 | История
URL: http://kb.mista.ru/article.php?id=735

Ключевые слова: форма, файл, сохранение формы, реквизиты формы в файл, сохранение формы в файл,


Cохранение значений реквизитов формы в файл - таблицу значений тоже сохраняет.
Код следующий:
Процедура СохранитьЗначенияФормы()
   СтруктураЭлементов = Новый Структура;
   Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
       Если ЗначениеЗаполнено(ЭлементФормы.Данные) Тогда
           ЗнВСтр = ЗначениеВСтрокуВнутр(ЭлементФормы.Значение);
           СтруктураЭлементов.Вставить(ЭлементФормы.Имя, ЗнВСтр);
       КонецЕсли;    
   КонецЦикла;    
   ЗначениеВФайл("O:\Load Upload (1c data authomat exchange)\Buh\PoFirmam.sav", СтруктураЭлементов);
КонецПроцедуры

Процедура ВосстановитьЗначенияФормы()
   СтруктураЭлементов = Новый Структура;
   СтруктураЭлементов = ЗначениеИзФайла("O:\Load Upload (1c data authomat exchange)\Buh\PoFirmam.sav");
   Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
       Попытка
           ЭлементФормы.Значение = ЗначениеИзСтрокиВнутр(СтруктураЭлементов[ЭлементФормы.Имя])  
       Исключение
       КонецПопытки;
   КонецЦикла;  
КонецПроцедуры

Авторство: SuperMario (http://www.forum.mista.ru/users.php?id=10887)
Ссылка на статью с кодом: http://www.itdepartament.ru/index.php/archives/35
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика