Книга знаний

Рекламное место пустует
1С:Предприятие / Приемы программирования / Внешние обработки

Прервать обработку проведения по нажатию Esc

Попытка прервать проведение документов в 1С:Предприятие 7.7 затруднена: нажатие Esc останавливает проведение документа, но 1С тут же начинает проводить новый. Поэтому, если проведение завершилось неудачно, я делаю цикл, в котором уже можно прервать обработку проведения вторым нажатием Esc.Автор статьи: romix
Последняя редакция №1 от 06.02.08
URL: http://kb.mista.ru/article.php?id=635

Ключевые слова: проведение, прервать, нажатие, Esc


//*******************************************
Процедура Сформировать()
    док=СоздатьОбъект("Документ.Накладная");
    док.ВыбратьДокументы(НачДата, КонДата);
    Пока док.ПолучитьДокумент() = 1 Цикл
        Если док.Проведен()=0 Тогда
            Продолжить;
        КонецЕсли;
        Состояние("*"+док.ДатаДок+" "+док);
        Если док.Провести()=0 Тогда
            Для й=1 по 10000 Цикл //пустой цикл, в котором можно еще раз нажать Esc
                Состояние("пауза: "+й);
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика