Книга знаний

1С:Предприятие / Приемы программирования / Интернет-технологии

Получение всех гиперссылок документа HTML

Автор статьи: romix | Редакторы: Гений 1С
Последняя редакция №2 от 15.01.08 | История
URL: http://kb.mista.ru/article.php?id=610

///////////////////////////////////////////////////////////////////////
Процедура sleep(ms)
    стр="Ожидание "+ТекущееВремя();
    Состояние(стр);
    сек=цел(ms/1000);
    ВвестиСтроку(стр, стр, 100, 0, сек);
КонецПроцедуры    


///////////////////////////////////////////////////////////////////////
Процедура ПолучитьВсеГиперссылкиДокумента()
    True=-1; 
    False=0;
    //
    oIE = CreateObject("InternetExplorer.Application");
    oIE.Visible=True;
    oIE.Navigate("http://kb.mista.ru/"); //адрес для скачивания
    
    While oIE.Busy()=True Do
        sleep(1000);
    EndDo;
    
    doc1=oIE.Document;
    
      obj1_=doc1.getElementsByTagName("a"); //Выбираем все теги <a>
      чДочернихЭлементов1=obj1_.length();
      Для i1=0 по чДочернихЭлементов1-1 Цикл  
          obj1=obj1_.item(i1);
          
          strText = СокрЛП(obj1.InnerHTML);
          Сообщить("Название ссылки: "+strText);
          
          attr= obj1.attributes.getNamedItem("href");
          strUrl = attr.NodeValue;

          Сообщить("Адрес ссылки: "+strUrl);
      КонецЦикла;    
КонецПроцедуры    
   

От Гения 1С:
KISS - делай это проще, дурачок!
doc1.links - колекция всех ссылок документа...
Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика