Книга знаний

1С:Предприятие / v8 / Приемы программирования / OLE, COM

v8: Заполнение полей документа Word (шаблон Active Document)

Пример позволяет заполнить шаблон Microsoft Word как активный документ в 1С:Предприятие 8.0.Автор статьи: romix | Редакторы:
Последняя редакция №3 от 06.11.07 | История
URL: http://kb.mista.ru/article.php?id=452

Ключевые слова: Word, Active Document, ActiveDocument, Application, заполнение, поле


В Конфигураторе

Макеты - правый клик - Добавить
Тип макета: Active document
Создать новый - Документ Microsoft Word

Меню Вставка - Поле - Автоматизация - DocVariable
Написать имя поля в графе "Новое имя:" ДатаПриказа

В модуле формы документа создаем кнопку, и в ее обработчике пишем:

Процедура ОсновныеДействияФормыWord(Кнопка)
   АктивныйДокумент = ПолучитьМакет("Макет");
   КомОбъект = АктивныйДокумент.Получить();
   
   КомОбъект.Application.Visible=1;
   КомОбъект.Variables.Item("ДатаПриказа").Value="24.01.2007";
   КомОбъект.Fields.UpDate();

   КомОбъект.PrintOut(); //распечатать документ

   //Ожидание окончания отправки на печать...
   Пока objWord.Application.BackgroundPrintingStatus<>0 Цикл
     Предупреждение("Ожидание",1);
   КонецЦикла;  

   КомОбъект.Application.Quit(); //закрыть Word
   КомОбъект = 0;
КонецПроцедуры





Другой вариант: добавляем не поле, а Закладку

http://itland.ru/forum/index.php?showtopic=5238

Меню Вставка-Закладка... Задаем ее имя ("КуКу").

Процедура ОсновныеДействияФормыWord(Кнопка)
   АктивныйДокумент = ПолучитьМакет("Макет");
   КомОбъект = АктивныйДокумент.Получить();
   КомОбъект.Application.Visible=1;
   КомОбъект.Bookmarks(СокрЛП("КуКу")).Select();
   КомОбъект.Application.Selection.TypeText(СокрЛП("крокодил"));
КонецПроцедуры

Закладка

Описание | Рубрикатор | Поиск | ТелепатБот | Захваченные статьи | Установки | Форум
© Станислав Митичкин (Волшебник), 2005-2011 | Mista.ru

Яндекс.Метрика